长短支压精美主图指标公式-大智慧公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文内容

游戏娱乐平台注册就送25

相关标签:波浪理论指标公式 、 通达信波浪尺指标公式 、 波浪尺的画法视频 、 波浪尺的原理 、 波浪提示指标公式 、 通达信趋势浪指标 、 波浪尺理论 、 135指标公式 、 波浪尺最正确的方法 、 波浪尺的应用技巧 、 波浪尺数值判断技巧 、 波浪尺的运用 、

 

长短支压精美主图直接上源码,并在此感谢一品大师的“烧香拜佛”理念!(个人理解在图片中,欢迎批评指正。)

 

 

 

原理解析:


 

 来源:程序化99( WWW.naturesnaturalbeauty.com )

源码:

 


DRAWutf-8(c>0),color000000;
DRAWTEXTABS(12,8, '所属板块: '+BKNAME),Color888888;
DRAWTEXTABS(12,21,'每股收益: '+NUMTOSTRN(FINANCE2(3),2)+'元 '+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),1)+'倍 '+' 每股公积金:'+NUMTOSTRN(FINANCE2(7),2)+'元'),Color888888;
DRAWTEXTABS(12,34,'总 股 本: '+NUMTOSTRN(FINANCE2(35),2)+'万股'),Color888888;
DRAWTEXTABS(12,47,'流通 A股: '+NUMTOSTRN(FINANCE2(37),2)+'万股'),Color888888;
{以下设置长支压}
AA1:=REF(CLOSE,20)=HHV(CLOSE,2*20+1);
AB1:=FILTER(AA1,20);
AC1:=BACKSET(AB1,20+1);
HD:=FILTER(AC1,20);
AA2:=REF(CLOSE,20)=LLV(CLOSE,2*20+1);
B2:=FILTER(AA2,20);
AC2:=BACKSET(B2,20+1);LD:=FILTER(AC2,20);A:=REF(CLOSE,BARSLAST(HD));
B:=REF(CLOSE,BARSLAST(LD));
t1:=BARSLAST(HD) and BARSLAST(LD) AND NOT(LD);
STICKLINE(t1,A,A,6,0),ColorDD8800;STICKLINE(t1,B,B,6,0),Color00AA00;
{以下设置短支压}
ST:=(CLOSE/OPEN-1)*100;
Z,:=(C/REF(C,1)-1)*100;
SX1:=ST>3 AND ST=HHV(ST,6);
SX2:=Z,>3 AND Z,=HHV(Z,,6);
SX3:=Z,>=9 AND CLOSE=HIGH;
烧香:=IF(SX1 OR SX2 OR SX3,1,0);
DYSJ:=BARSLAST(烧香);
跟踪:=IF(DYSJ<=13 AND COUNT(C>REF(L,DYSJ),DYSJ)>=DYSJ-1,DYSJ,0);
关注:=IF(DYSJ>=4 AND COUNT(C>REF(C,DYSJ),3)>=3,REF(C,DYSJ),REF(L,DYSJ));
②:=IF(关注=REF(L,DYSJ),REF(C,DYSJ),REF(L,DYSJ));
PUU:=BACKSET(DISPSTATUS=2,跟踪);
压力:STICKLINE(跟踪,②,关注,10,0),COLOR666666,LAYER7;
支撑:STICKLINE(跟踪,关注,②,10,0),COLOR666666,LAYER7;
{压力:STICKLINE(PUU AND 跟踪,②,关注,10,0),COLOR666666,LAYER7;
支撑:STICKLINE(PUU AND 跟踪,关注,②,10,0),COLOR666666,LAYER7;}
DRAWTEXT(烧香,L,'﹡'),COLOR0000FF,ALIGN1;
DRAWFLAGTEXT(烧香,LOW,'⊙走上短线平台,注意上下支撑!'),COLOR0000FF;
{以下设置立体K线};
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.5,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0) ,COLOR0000ff;
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
stickline(var9Q,c,(o+c)/2,8,0),color000055;
stickline(var9Q,c,(o+c)/2,7,0),color000066;
stickline(var9Q,c,(o+c)/2,6,0),color000077;
stickline(var9Q,c,(o+c)/2,5,0),color000099;
stickline(var9Q,c,(o+c)/2,4,0),color0000bb;
stickline(var9Q,c,(o+c)/2,3,0),color0000dd;
stickline(var9Q,c,(o+c)/2,1.5,0),color0000ff;
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
stickline(varaQ,c,(o+c)/2,8,0),colorff11ff;
stickline(varaQ,c,(o+c)/2,7,0),colorff33ff;
stickline(varaQ,c,(o+c)/2,6,0),colorff55ff;
stickline(varaQ,c,(o+c)/2,5,0),colorff77ff;
stickline(varaQ,c,(o+c)/2,4,0),colorff99ff;
stickline(varaQ,c,(o+c)/2,3,0),colorffbbff;
stickline(varaQ,c,(o+c)/2,1.5,0),colorffddff;
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
stickline(varbQ,c,(o+c)/2,8,0),color333333;
stickline(varbQ,c,(o+c)/2,7,0),color555555;
stickline(varbQ,c,(o+c)/2,6,0),color777777;
stickline(varbQ,c,(o+c)/2,5,0),color999999;
stickline(varbQ,c,(o+c)/2,4,0),colorbbbbbb;
stickline(varbQ,c,(o+c)/2,3,0),colordddddd;
stickline(varbQ,c,(o+c)/2,1.5,0),colorffffff;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
stickline(varcQ,o,(o+c)/2,8,0),color003300;
stickline(varcQ,o,(o+c)/2,7,0),color005500;
stickline(varcQ,o,(o+c)/2,6,0),color007700;
stickline(varcQ,o,(o+c)/2,5,0),color009900;
stickline(varcQ,o,(o+c)/2,4,0),color00bb00;
stickline(varcQ,o,(o+c)/2,3,0),color00dd00;
stickline(varcQ,o,(o+c)/2,1.5,0),color00ff00;
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
stickline(vardQ,o,(o+c)/2,8,0),colorff1100;
stickline(vardQ,o,(o+c)/2,7,0),colorff3300;
stickline(vardQ,o,(o+c)/2,6,0),colorff5500;
stickline(vardQ,o,(o+c)/2,5,0),colorff7700;
stickline(vardQ,o,(o+c)/2,4,0),colorff9900;
stickline(vardQ,o,(o+c)/2,3,0),colorffbb00;
stickline(vardQ,o,(o+c)/2,1.5,0),colorffdd00;CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.naturesnaturalbeauty.com',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指标公式');




 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容