止损位 大智慧L2指标公式源码-大智慧公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文内容

游戏娱乐平台注册就送25

相关标签:kdj指标公式源代码 、 kdj是什么指标 、 skdj指标公式 、 无敌kdj指标公式 、 kdj指标参数设置 、 kdj指标源码 、 kdj指标怎么看 、 超级kdj指标公式 、 kdj公式指标参数 、 kdj指标参数最佳设置 、 kdj指标详解图解短线 、 kdj指标的计算方法 、

 

 

原理解析:


 

 来源:程序化99( WWW.naturesnaturalbeauty.com )

源码:

 

 

{止损}
A1:=REF(CLOSE,1);
A2:=((SMA((MAX((CLOSE - A1),0)),5,1)) / (SMA(ABS((CLOSE - A1)),5,1))) * 100;
A3:=SUM((MAX((MAX((HIGH - LOW),ABS((HIGH - A1)))),ABS((LOW - A1)))),10);
A4:=HIGH - (REF(HIGH,1));
A5:=(REF(LOW,1)) - LOW;
A6:=SUM((IF(((A4 > 0) AND (A4 > A5)),A4,0)),10);
A7:=SUM((IF(((A5 > 0) AND (A5 > A4)),A5,0)),10);
A8:=(A6 * 100) / A3;
A9:=(A7 * 100) / A3;
A10:=MA(((ABS((A9 - A8)) / (A9 + A8)) * 100),5);
A11:=A2 + A10;
A12:=((A10 + (REF(A10,5))) / 2) + A2;
A13:=(100 * ((HHV(HIGH,10)) - CLOSE)) / ((HHV(HIGH,10)) - (LLV(LOW,10)));
A14:=A2 - A13;
A15:=A11 + A14;
A:=LLV(A15,1);
B:=IF((A < 0),0,A);
STICKLINE(A>IF(CAPITAL=0,1,5),15,15+A,3,0),COLOR004444;
STICKLINE(A>IF(CAPITAL=0,1,5),15,15+A,1,0),COLOR00FFFF;
STICKLINE(A<IF(CAPITAL=0,1,5),15,15+A,3,0),COLOR444400;
STICKLINE(A<IF(CAPITAL=0,1,5),15,15+A,1,0),COLORFFCC00;
STICKLINE(B>0,0,0+B,2,0),COLOR000044;
STICKLINE(B>0,0,0+B,1,0),COLOR0000FF;
STICKLINE(B<0,0,0+B,2,0),COLOR004400;
STICKLINE(B<0,0,0+B,1,0),COLOR00FF00;
M:=REF(B,1);
DRAWTEXT((M=0 AND B>M),-5,'买'),ColorFF00FF;
DRAWTEXT((M>180 AND B>M),280,'卖'),ColorFF8000;
DRAWTEXT(REF((M=0 AND B>M),1) AND A<REF(A,1),200,'止损'),Color008000;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容