请老师修改指标-游戏娱乐平台注册就送25免费注册即送体验金知识 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25

游戏娱乐平台注册就送25

  • 咨询内容:  老师这个指标代码没看懂,但是感觉好像是逆势标注,即在红色多头线上标注顶型,绿色空头线下标注底型,能不能改成顺势啊 ,比如 在60周期移动平均线上标注底型,线下标注顶型?

    重心线:(H+L+O+C*3)/6;NX:=(3*CLOSE+LOW+OPEN+HIGH)/6;牛线:=(20*NX+19*REF(NX,1)+18*REF(NX,2)+17*REF(NX,3)+16*REF(NX,4)+15*REF(NX,5)+14*REF(NX,6)+13*REF(NX,7)+12*REF(NX,8)+11*REF(NX,9)+10*REF(NX,10)+9*REF(NX,11)+8*REF(NX,12)+7*REF(NX,13)+6*REF(NX,14)+5*REF(NX,15)+4*REF(NX,16)+3*REF(NX,17)+2*REF(NX,18)+REF(NX,20))/210;牛熊线:MA(牛线,6),COLORGREEN,LINETHICK2;IF(牛熊线<=牛线,牛熊线,NULL),COLORRED,LINETHICK2;IF(牛熊线>牛线,牛熊线,NULL),COLORGREEN,LINETHICK2;简底:=H>REF(H,1) AND REF(H,1)<REF(H,2) AND L>REF(L,1) AND REF(L,1)<REF(L,2);简顶:=H<REF(H,1) AND REF(H,1)>REF(H,2) AND L<REF(L,1) AND REF(L,1)>REF(L,2);包含1:=REF(H,1)>=REF(H,2) AND REF(L,1)<=REF(L,2);包含2:=REF(H,1)<=REF(H,2) AND REF(L,1)>=REF(L,2);包底1:=H>REF(H,2) AND REF(H,2)<REF(H,3) AND L>REF(L,1) AND REF(L,1)<REF(L,3);包底2:=H>REF(H,1) AND REF(H,1)<REF(H,3) AND L>REF(L,2) AND REF(L,2)<REF(L,3);包顶1:=H<REF(H,1) AND REF(H,1)>REF(H,3) AND L<REF(L,2) AND REF(L,2)>REF(L,3);包顶2:=H<REF(H,2) AND REF(H,2)>REF(H,3) AND L<REF(L,1) AND REF(L,1)>REF(L,3);复底:=IF(包含1,包底1,IF(包含2,包底2,简底));复顶:=IF(包含1,包顶1,IF(包含2,包顶2,简顶));底分型:=IF(BARSLAST(CROSS(牛熊线,重心线))>3,FILTER(BACKSET(FILTER(复底 AND 重心线<牛熊线,3),2),1),0);顶分型:=IF(BARSLAST(CROSS(重心线,牛熊线))>3,FILTER(BACKSET(FILTER(复顶 AND 重心线>牛熊线,3),2),1),0);//STICKLINE1(底分型,C,O,1,0),COLORFF00FF,LINETHICK2;//STICKLINE1(底分型,C,O,1,0),COLORFF00FF,LINETHICK2;//STICKLINE1(底分型,H,L,1,0),COLORFF00FF,LINETHICK2;//STICKLINE1(顶分型,C,O,1,0),COLORYELLOW,LINETHICK2;//STICKLINE1(顶分型,C,O,1,0),COLORYELLOW,LINETHICK2;//STICKLINE1(顶分型,H,L,1,0),COLORYELLOW,LINETHICK2;DRAWTEXT(底分型,L,'型',VALIGN0,COLORYELLOW,LINETHICK1;DRAWTEXT(顶分型,H,'型',COLORYELLOW,LINETHICK1;

     

     来源:程序化99

  • 游戏娱乐平台注册就送25技术人员: 最后两句这么改下
    DRAWTEXT(底分型&&C<MA(C,60),L,'型',VALIGN0,COLORYELLOW,LINETHICK1;DRAWTEXT(顶分型&&C>MA(C,60),H,'型',COLORYELLOW,LINETHICK1;

     

     来源: WWW.naturesnaturalbeauty.com

  • 游戏娱乐平台注册就送25客服:  老师 这两句是什么意思啊? 底分型:=IF(BARSLAST(CROSS(牛熊线,重心线))>3,FILTER(BACKSET(FILTER(复底 AND 重心线<牛熊线,3),2),1),0);顶分型:=IF(BARSLAST(CROSS(重心线,牛熊线))>3,FILTER(BACKSET(FILTER(复顶 AND 重心线>牛熊线,3),2),1),0);

     

  • 网友回复:   
  • 网友回复:距离 
  • 网友回复:复底和重心线<牛熊线这个条件的第一根K线,否则为1  
  • 网友回复:顶分型= 
  • 网友回复:距离 
  • 网友回复:复顶和重心线》牛熊线这个条件的第一根K线,否则为1

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容