替天行道,和谐兽价千万,臭名昭著的财神红绿点指标-其他软件公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

游戏娱乐平台注册就送25

相关标签:红绿电波买卖公式 、 通达信神奇电波指标 、 神奇波段顶底指标公式 、 顶底神奇判断指标公式 、 bs点的神奇指标公式源码 、 通达信公式神奇电波 、 红绿通道指标公式 、 同花顺神奇电波公式 、 红绿k线指标公式 、 神奇电波公式无未来 、 神奇电波指标源码 、 关于神奇电波选股的问题 、

 

替天行道,和谐兽价千万,臭名昭著的财神红绿点指标
 

 

原理解析:


 

 来源:程序化99( WWW.naturesnaturalbeauty.com )

源码:

 

 


{程序化交易 www.naturesnaturalbeauty.com }
{财神DDX}
资金 : (EMA(CLOSE,5) - EMA(CLOSE,888888888888888))*1,COLORYELLOW,LINETHICK2;
趋势 : EMA(资金,888888888888888),colorff9900,LINETHICK1;
升降 : 2*(资金-趋势), ColorFFFFFF,LINETHICK88;
画渐变背景色(收盘价>0, RGB颜色值(1,3333,8888), RGB颜色值(100,7777,8888),3);;
RSV:=(CLOSE-LLV(LOW,8888888888))/(HHV(HIGH,8888888888)-LLV(LOW,8888888888))*200;
d:=SMA(RSV,5,1), COLORSTICK;
a:=SMA(d,3,1), COLORSTICK;
ddx:3*d-2*a, COLORSTICK;

STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,8,0 ),COLOR00aaff,LINETHICK1000;
STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,6.6,0 ),COLOR00bbff,LINETHICK1000;
STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,4.4,0 ),COLOR00ccff,LINETHICK1000;
STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,3.3,0 ),COLOR00ddff,LINETHICK1000;
STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,2.2,0 ),COLOR00eeff,LINETHICK1000;
STICKLINE(ddx<REF(ddx,1)and ddx>50,0,ddx,1.1,0 ),COLOR00ffff,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,8 ,0 ),COLOR0000aa,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,6.6 ,0 ),COLOR0011bb,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,4.4,0 ),COLOr0022cc,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,3.3 ,0 ),COLOR0033dd,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,2.2 ,0 ),COLOR0044ee,LINETHICK1000;
STICKLINE(ddx>=REF(ddx,1)and ddx>50,0,ddx,1.1 ,0 ),COLOR0055ff,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,8,0 ),COLOraa00bb,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,6.6 ,0 ),COLORbb11bb,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,4.4,0 ),COLOrcc22bb,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,3.3,0 ),COLORdd33bb,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,2.2 ,0 ),COLORee44bb,LINETHICK1000;
STICKLINE(ddx>REF(ddx,1)and ddx<50,0,ddx,1.1 ,0 ),COLORff55bb,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,8,0 ),COLOrffaa00,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,6.6 ,0 ),COLORffbb11,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,4.4,0 ),COLOrffcc22,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,3.3 ,0 ),COLORffdd33,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,2.2 ,0 ),COLORffee44,LINETHICK1000;
STICKLINE(ddx<=REF(ddx,1)and ddx<50,0,ddx,1.1 ,0 ),COLORffff55,LINETHICK1000;

财神DDX排序
{5行KD_表格数据引用}
ddx上拐01:="KD.ddx上拐#MIN1";ddx上拐05:="KD.ddx上拐#MIN5";ddx上拐15:="KD.ddx上拐#MIN15";ddx上拐30:="KD.ddx上拐#MIN30";ddx上拐60:="KD.ddx上拐#MIN60";ddx上拐R :="KD.ddx上拐#DAY";ddx上拐Z :="KD.ddx上拐#WEEK";ddx上拐Y :="KD.ddx上拐#MONTH";ddx上拐N :="KD.ddx上拐#YEAR";
ddx下拐01:="KD.ddx下拐#MIN1";ddx下拐05:="KD.ddx下拐#MIN5";ddx下拐15:="KD.ddx下拐#MIN15";ddx下拐30:="KD.ddx下拐#MIN30";ddx下拐60:="KD.ddx下拐#MIN60";ddx下拐R :="KD.ddx下拐#DAY";ddx下拐Z :="KD.ddx下拐#WEEK";ddx下拐Y :="KD.ddx下拐#MONTH";ddx下拐N :="KD.ddx下拐#YEAR";
ddx上行01:="KD.ddx上行#MIN1";ddx上行05:="KD.ddx上行#MIN5";ddx上行15:="KD.ddx上行#MIN15";ddx上行30:="KD.ddx上行#MIN30";ddx上行60:="KD.ddx上行#MIN60";ddx上行R :="KD.ddx上行#DAY";ddx上行Z :="KD.ddx上行#WEEK";ddx上行Y :="KD.ddx上行#MONTH";ddx上行N :="KD.ddx上行#YEAR";
ddx下行01:="KD.ddx下行#MIN1";ddx下行05:="KD.ddx下行#MIN5";ddx下行15:="KD.ddx下行#MIN15";ddx下行30:="KD.ddx下行#MIN30";ddx下行60:="KD.ddx下行#MIN60";ddx下行R :="KD.ddx下行#DAY";ddx下行Z :="KD.ddx下行#WEEK";ddx下行Y :="KD.ddx下行#MONTH";ddx下行N :="KD.ddx下行#YEAR";

{14行}{表框部份}
p:=SYSPARAM(1);
DRAWTEXTEX(c,0,135,0 ,'──────────────────────────────────────────────────'),Color00AAAA;
DRAWTEXTEX(c,0,135,20,'──────────────────────────────────────────────────'),Color00AAAA;
DRAWTEXTEX(c,0,135,40,'──────────────────────────────────────────────────'),Color00AAAA;



DRAWTEXTEX(c,0,130,5,'│ │ │ │ │ │ │ │ │ │ │'),Color00AAAA;
DRAWTEXTEX(c,0,130,17 ,'│ │ │ │ │ │ │ │ │ │ │'),Color00AAAA;
DRAWTEXTEX(c,0,130,29 ,'│ │ │ │ │ │ │ │ │ │ │'),Color00AAAA;
DRAWTEXTEX(c,0,130,41 ,'│ │ │ │ │ │ │ │ │ │ │'),Color00AAAA;




DRAWTEXTEX(c,0,130,10,' 周期: 1分 5分 15分 30分 60分 日 周 月 年'),ColorDEDEDE;
DRAWTEXTEX(c,0,130,30,' ddx状况:'),ColorDEDEDE;

{37行显示ddx↑行}
DRAWTEXTEX(C AND ddx上行01[P],0,200,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行01[P],0,200,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行05[P],0,260,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行05[P],0,260,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行15[P],0,320,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行15[P],0,320,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行30[P],0,380,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行30[P],0,380,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行60[P],0,440,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行60[P],0,440,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行R[P],0,500,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行R[P],0,500,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行Z[P],0,560,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行Z[P],0,560,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行Y[P],0,620,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行Y[P],0,620,32,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行N[P],0,680,30,'↑'),COLORRED;
DRAWTEXTEX(C AND ddx上行N[P],0,680,32,'↑'),COLORRED;
{56行显示K↓行}
DRAWTEXTEX(C AND ddx下行01[P],0,210,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行01[P],0,210,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行05[P],0,270,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行05[P],0,270,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行15[P],0,330,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行15[P],0,330,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行30[P],0,390,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行30[P],0,390,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行60[P],0,450,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行60[P],0,450,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行R[P],0,510,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行R[P],0,510,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行Z[P],0,570,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行Z[P],0,570,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行Y[P],0,630,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行Y[P],0,630,32,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行N[P],0,690,30,'↓'),COLORGREEN;
DRAWTEXTEX(C AND ddx下行N[P],0,690,32,'↓'),COLORGREEN;
{75行显示K上拐∨}
DRAWTEXTEX(C AND ddx上拐01[P],0,225,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐01[P],0,225,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐05[P],0,285,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐05[P],0,285,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐15[P],0,345,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐15[P],0,345,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐30[P],0,405,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐30[P],0,405,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐60[P],0,465,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐60[P],0,465,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐R[P],0,525,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐R[P],0,525,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐Z[P],0,585,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐Z[P],0,585,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐Y[P],0,645,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐Y[P],0,645,32,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐N[P],0,705,30,'∨'),COLORRED;
DRAWTEXTEX(C AND ddx上拐N[P],0,705,32,'∨'),COLORRED;
{94行显示K下拐∧}
DRAWTEXTEX(C AND ddx下拐01[P],0,240,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐01[P],0,240,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐05[P],0,300,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐05[P],0,300,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐15[P],0,360,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐15[P],0,360,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐30[P],0,420,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐30[P],0,420,32,'∧'),COLORGREEN;
DRAWTEXTEX(C and ddx下拐60[P],0,480,30,'∧'),COLORGREEN;
DRAWTEXTEX(C and ddx下拐60[P],0,480,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐R[P],0,540,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐R[P],0,540,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐Z[P],0,600,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐Z[P],0,600,32,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐Y[P],0,660,30,'∧'),COLORGREEN;
DRAWTEXTEX(C AND ddx下拐Y[P],0,660,32,'∧'),COLORGREEN;
DRAWTEXTEX(C and ddx下拐N[P],0,720,30,'∧'),COLORGREEN;
DRAWTEXTEX(C and ddx下拐N[P],0,720,32,'∧'),COLORGREEN;

财:"kdj.k",linethick,COLORWHITE;
神:"kdj.d",linethick0,COLORYELLOW;
q:=SYSPARAM(3)-SYSPARAM(2);
p:=SYSPARAM(3);
kh:=hhv(h,q);
kL:=LLv(L,q);
dh:=hhv(max(财,神),q);
dL:=LLv(min(财,神),q);
bd:=(kh-kL)/(dh-dL)/3;
wk:=(kh-kL)/3;
wd:=(kh+kL-(dh+dL)*bd)/2-wk[p];
PARTLINE(1,财*bd[p]+wd[p]),linethick5,COLORWHITE;
PARTLINE(1,神*bd[p]+wd[p]),linethick5,COLORYELLOW;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),LOW,HIGH,0.1,0),,colorFF;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),OPEN,CLOSE,7,0),,colorFF;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),LOW,HIGH,0.1,0),,colorFFFF00;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),OPEN,CLOSE,7,0),,colorFFFF00;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),LOW,HIGH,0.1,0),,colorFF;
STICKLINE(((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1)))),OPEN,CLOSE,7,0),,colorFF;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),LOW,HIGH,0.1,0),,colorFFFF00;
STICKLINE(((CLOSE < OPEN) OR ((CLOSE = OPEN) AND (CLOSE <= REF(CLOSE,1)))),OPEN,CLOSE,7,0),,colorFFFF00;
工作线:指数平滑移动平均(收盘价,14),PRECISION2,COLORYELLOW,LINETHICK5;
LOCK:=条件函数(当前日期<1120923,1,0);
画分段线(指数平滑移动平均((2*收盘价+最高价+最低价)/4,6)>向前引用(指数平滑移动平均((2*收盘价+最高价+最低价)/4,6),1),指数平滑移动平均((2*收盘价+最高价+最低价)/4,5)),colorFF;
画分段线(指数平滑移动平均((2*收盘价+最高价+最低价)/4,6)<向前引用(指数平滑移动平均((2*收盘价+最高价+最低价)/4,6),1),指数平滑移动平均((2*收盘价+最高价+最低价)/4,5)),colorFF00;
画分段线(指数平滑移动平均((2*收盘价+最高价+最低价)/4,10)>向前引用(指数平滑移动平均((2*收盘价+最高价+最低价)/4,13),1),指数平滑移动平均((2*收盘价+最高价+最低价)/4,13)),colorFF;
画分段线(指数平滑移动平均((2*收盘价+最高价+最低价)/4,10)<向前引用(指数平滑移动平均((2*收盘价+最高价+最低价)/4,13),1),指数平滑移动平均((2*收盘价+最高价+最低价)/4,13)),LINETHICK2,colorFF00;
画分段线(指数平滑移动平均((最低价+收盘价+开盘价)/3,453)>向前引用(指数平滑移动平均((最低价+收盘价+开盘价)/3,453),1),向前引用(指数平滑移动平均((最低价+收盘价+开盘价)/3,377),1)),LINETHICK3,colorFF;
画分段线(指数平滑移动平均((最低价+收盘价+开盘价)/3,453)<向前引用(指数平滑移动平均((最低价+收盘价+开盘价)/3,453),1),向前引用(指数平滑移动平均((最低价+收盘价+开盘价)/3,377),1)),colorFF00,LINETHICK8;
画分段线((指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,89))/2>向前引用((指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,89))/2,1),(指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,55))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,89))/2<向前引用((指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,89))/2,1),(指数平滑移动平均(最低价,55)+指数平滑移动平均((收盘价+最低价)/2,55))/2),点状线,colorFF00;
画分段线((指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,233))/2>向前引用((指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,233))/2,1),(指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,144))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,233))/2<向前引用((指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,233))/2,1),(指数平滑移动平均(最低价,144)+指数平滑移动平均((收盘价+最低价)/2,144))/2),点状线,colorFF00;
画分段线((指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,377))/2>向前引用((指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,377))/2,1),(指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,233))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,377))/2<向前引用((指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,377))/2,1),(指数平滑移动平均(最低价,233)+指数平滑移动平均((收盘价+最低价)/2,233))/2),点状线,colorFF00;
画分段线((指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,1597))/2>向前引用((指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,1597))/2,1),(指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,610))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,1597))/2<向前引用((指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,1597))/2,1),(指数平滑移动平均(最低价,610)+指数平滑移动平均((收盘价+最低价)/2,610))/2),点状线,colorFF00;
画分段线((指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,4181))/2>向前引用((指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,4181))/2,1),(指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,2584))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,4181))/2<向前引用((指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,4181))/2,1),(指数平滑移动平均(最低价,2584)+指数平滑移动平均((收盘价+最低价)/2,2584))/2),点状线,colorFF00;
画分段线((指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,6765))/2>向前引用((指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,6765))/2,1),(指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,4181))/2),点状线,colorFF;
画分段线((指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,6765))/2<向前引用((指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,6765))/2,1),(指数平滑移动平均(最低价,4181)+指数平滑移动平均((收盘价+最低价)/2,4181))/2),点状线,colorFF00;
Zcb1:=累加到指定值周期数(成交量 ,流通盘大小*1);{累计换手=100%的周期}
Zcb2:=求和(成本分布(10),Zcb1)/Zcb1;{在A周期里获利10%的平均价}
Zcb3:=求和(成本分布(20),Zcb1)/Zcb1;{在A周期里获利20%的平均价}
Zcb4:=求和(成本分布(30),Zcb1)/Zcb1;{在A周期里获利30%的平均价}
Zcb5:=求和(成本分布(40),Zcb1)/Zcb1;{在A周期里获利40%的平均价}
Zcb6:=求和(成本分布(50),Zcb1)/Zcb1;{在A周期里获利50%的平均价}
庄本:(5*Zcb2+4*Zcb3+3*Zcb4+2*Zcb5+Zcb6)/15,PRECISION2,LINETHICK3,COLOR1199ff;{求出庄家成本}
{低位密集}

;
年线:指数平滑移动平均(收盘价,240),PRECISION2,,ColorFF80FF;
ZDF:=(收盘价-向前引用(收盘价,1))/向前引用(收盘价,1)*100;
画柱线(ZDF>9.8,开盘价,收盘价,6,0),coloryellow;

AC:=收盘价;
转强:=加权移动平均(最高价,6);
转弱:=加权移动平均(最低价,6);
B:=收盘价*0;
FOR I=13+1 TO 序列数据量 DO BEGIN
条件函数 AC[I]>转强[I-1] THEN
B[I]:=1;ELSE
条件函数 AC[I]<转弱[I-1] THEN
B[I]:=-1;ELSE
B[I]:=B[I-1];
END;
转折线:条件函数(B=-1,简单移动平均(最高价,6),简单移动平均(最低价,6)),LINETHICK2,colorFFFFFF;
生命线:=(指数平滑移动平均(收盘价,55)+指数平滑移动平均(收盘价,233))/2,LINETHICK2,COLORCC33FF;
道中仙:=之字转向(3,55),LINETHICK1,COLORGREEN;
显示文字(交叉函数(向前引用(之字转向(3,88888888),1),之字转向(3,88888888)),最高价*0.96,'抛了吧'),ColorFFFFFF;
显示文字(交叉函数(之字转向(3,88888888),向前引用(之字转向(3,88888888),1)),最低价*1.09,'关注'), ,ColorFFFFFF;

财神红绿点
供财神买 := EMA(CLOSE,5) - EMA(CLOSE,8888888888);求财神买 := EMA(供财神买,8888888888);
买 : 2*(供财神买-求财神买), COLORSTICK,LINETHICK8888;
DRAWutf-8(CLOSE>0, COLORRGB(100,3333,8888), COLORRGB(100,7777,8888),8);
DRAWBKBMP(( ( REF(买,0)-REF(买,1)>0)),'ddx'),;
DRAWBKBMP(( ( REF(买,0)-REF(买,1)<0)),'ddt');
财神红绿点。
文燕骗子1:=EMA(CLOSE,9999999999);
五天:=EMA(CLOSE,5);
骗子文 := 五天-文燕骗子1;
骗子燕 := EMA(骗子文,8888888888);
文燕骗术:2*(骗子文-骗子燕), COLORSTICK,LINETHICK8888;
DRAWutf-8(CLOSE>0, COLORRGB(100,3333,8888), COLORRGB(100,7777,8888),8);
DRAWBKBMP(( ( 文燕骗术-REF(文燕骗术,1)>0)),'图片1'),;
DRAWBKBMP(( ( 文燕骗术-REF(文燕骗术,1)<0)),'图片2'),;(沽权天下)
财神趋势工作线

MA1:简单移动平均(收盘价,14),Color80FFFF;


VAR1:=100-((90)*(最高值(最高价,21)-收盘价))/(最高值(最高价,21)-最低值(最低价,21));
VAR2:=100-((90)*(最高值(最高价,21)-收盘价))/(最高值(最高价,21)-最低值(最低价,21));
VAR3:=100-简单移动平均(((100)*(最高值(最高价,6)-收盘价))/(最高值(最高价,6)-最低值(最低价,6)),34);
年:简单移动平均(收盘价,55),ColorFFFFFF;



画柱线((收盘价>=年) AND (收盘价>=开盘价),收盘价,开盘价,7,0),CoLor0000FF;
画柱线((收盘价>=年) AND (收盘价>=开盘价),最高价,最低价,0,0),CoLor0000FF;
画柱线((收盘价>=年) AND (收盘价<开盘价),收盘价,开盘价,7,1),CoLor0000FF;
画柱线((收盘价>=年) AND (收盘价<开盘价),开盘价,最高价,0,0),CoLor0000FF;
画柱线((收盘价>=年) AND (收盘价<开盘价),收盘价,最低价,0,0),CoLor0000FF;
画柱线((收盘价<年) AND (收盘价>开盘价),收盘价,开盘价,7,1),CoLorFFFF00;
画柱线((收盘价<年) AND (收盘价<=开盘价),收盘价,开盘价,7,1),CoLorFFFF00;
画柱线((收盘价<年) AND (收盘价<=开盘价),最高价,最低价,0,1),CoLorFFFF00;
画柱线((收盘价<年) AND (收盘价>开盘价),收盘价,最高价,0,1),CoLorFFFF00;
画柱线((收盘价<年) AND (收盘价>开盘价),开盘价,最低价,0,1),CoLorFFFF00;
hh:=最高值(最高价,0);
hhh:=最高价;
aa:=上一次条件成立位置(最高价=hh[序列数据量]);
ba:=序列数据量-aa;
ja:=1;
tm1:=999999;
for i1=ba[序列数据量]+1 to 序列数据量 do begin
k1:=(hh[序列数据量]-hhh[i1])/ja;
条件函数 k1<tm1 then begin
tm1:=k1;
ts1:=ja;
end;
ja:=ja+1;
end;
A1:趋势线数值(最高价=hh[序列数据量] and aa=0,最高价,数据位置=序列数据量-aa[序列数据量]+ts1,最高价,0,0),colorffff54;
cha:=最高值(绝对值(最低价-a1),aa);
A2:a1-cha[序列数据量],colorffff54;
AI:a1-cha[序列数据量]/2,colorffff54,长虚线;

ll:=最低值(最低价,0);
lll:=最低价;
a3:=上一次条件成立位置(最低价=ll[序列数据量]);
b3:=序列数据量-a3;
j3:=1;
tm3:=999999;
for i3=b3[序列数据量]+1 to 序列数据量 do begin
k3:=(lll[i3]-ll[序列数据量])/j3;
条件函数 k3<tm3 then begin
tm3:=k3;
ts3:=j3;
end;
j3:=j3+1;
end;
B1:趋势线数值(最低价=ll[序列数据量] and a3=0,最低价,数据位置=序列数据量-a3[序列数据量]+ts3,最低价,0,0),color5454ff;
chb:=最高值(绝对值(最高价-b1),a3);
b2:b1+chb[序列数据量],color5454ff;
bi:b1+chb[序列数据量]/2,color5454ff,长虚线;input: N(21,5,100);财神涨停副
gws:=FRACPART(ref(c,1)*10);
qz:=INTPART(ref(c,1)*1)/100;
买:=之字转向(3,13)>向前引用(之字转向(3,13),1) AND 向前引用(之字转向(3,13),1)<向前引用(之字转向(3,13),2);
zt:=c=ref(c,1)+qz+if(gws>0.4,0.01,0) ;
xg : zt and买

财神中波
画渐变背景色(收盘价>0, RGB颜色值(1,0000,8888), RGB颜色值(100,5555,8865),3);
卖:之字转向(3,13)<向前引用(之字转向(3,13),1) AND 向前引用(之字转向(3,13),1)>向前引用(之字转向(3,13),2),COLORF0F000;
买:之字转向(3,13)>向前引用(之字转向(3,13),1) AND 向前引用(之字转向(3,13),1)<向前引用(之字转向(3,13),2), COLORRED;
买1:=之字转向(3,55)>向前引用(之字转向(3,55),1) AND 向前引用(之字转向(3,55),1)<向前引用(之字转向(3,55),2), COLORRED;
xg:买1>0 ;画柱线(xg,0,1.5,8,1),colorred;

财神资金趋势
资金:指数平滑移动平均((指数平滑移动平均(收盘价,1.5*1)-指数平滑移动平均(收盘价,1.5*88888888))/指数平滑移动平均(收盘价,1.5*88888888)*1000,3),ColorFFFFFF;
趋势:指数平滑移动平均(资金,1.5*88888888),ColorFFFFFF;
升降:2*(资金-趋势), ColorFFFFFF,LINETHICK18;
画渐变背景色(收盘价>0, RGB颜色值(1,3333,8888), RGB颜色值(100,7777,8888),3);
小起:显示文字(交叉函数("MACD.DIFF#WEEK"(88888888,5,88888888)
,"MACD.DEA#WEEK"(88888888,5,88888888)),500,'小起'),colorwhite;
小落:显示文字(交叉函数("MACD.DEA#WEEK"(88888888,5,88888888)
,"MACD.DIFF#WEEK"(88888888,5,88888888)),500,'小落')colorwhite;
大起:显示文字(交叉函数("MACD.DIFF#MONTH"(88888888,5,88888888)
,"MACD.DEA#MONTH"(88888888,5,88888888)),2000,'大起'),colorwhite;
大落:显示文字(交叉函数("MACD.DEA#MONTH"(88888888,5,88888888)
,"MACD.DIFF#MONTH"(88888888,5,88888888)),1000,'大落'),colorwhite;
画分段线(升降>=向前引用(升降,1) AND 升降>向前引用(升降,1),升降),color0096ff,LINETHICK3;
画分段线(升降<向前引用(升降,1) AND 升降<向前引用(升降,1),升降),colorgreen
,LINETHICK3;
画分段线(升降>=向前引用(升降,1) AND 升降<向前引用(升降,1),升降),color0096ff,LINETHICK3;
画分段线(升降<向前引用(升降,1) AND 升降>向前引用(升降,1),升降),colorgreen,LINETHICK3;0,colorwhite;

分析家公式网提醒:本源码转载创幻论坛原版,提醒公式有未来数据

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容