黄金VOL 两个公式 版(代编写指标选股公式)-其他软件公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

游戏娱乐平台注册就送25

相关标签:

 

献给只看MA和VOL的高手们___黄金VOL

经常来这里学习,不好意思只索取不奉献!!
献给只看MA和VOL的高手们___黄金VOL
这不是转贴哦!! 两个公式只有点点区别,随你喜欢!!

公式1:

 

原理解析:


 

 来源:程序化99( WWW.naturesnaturalbeauty.com )

源码:

 

 

 

VOLUME:VOL,VOLSTICK;
顶:=HHV(V,120);
底:=LLV(V,120);
H08:=底+(顶-底)*0.082;
H19:=底+(顶-底)*0.191;
H38:=底+(顶-底)*0.382;
H中:=底+(顶-底)*0.5;
H61:=底+(顶-底)*0.618;
H80:=底+(顶-底)*0.809;
【底】:REFDATE(底,DATE),COLORGREEN;
【0.082】:REFDATE(H08,DATE),COLORRED;
【0.191】:REFDATE(H19,DATE),COLORYELLOW;
【0.382】:REFDATE(H38,DATE),COLORMAGENTA;
【0.5】:REFDATE(H中,DATE),COLORWHITE;
【0.618】:REFDATE(H61,DATE),COLORLIRED;
【0.809】:REFDATE(H80,DATE),COLORYELLOW;
【顶】:REFDATE(顶,DATE),COLORCYAN;
{下面内容不显示,留下输出的空间给各位}
DRAWTEXT(ISLASTBAR,【顶】,'【天量】'),COLORCYAN;
DRAWTEXT(ISLASTBAR,【0.082】,'【0.082】'),COLORRED;
DRAWTEXT(ISLASTBAR,【0.191】,'【0.191】'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,【0.382】,'【0.382】'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,【0.5】,'【0.5】'),COLORWHITE;
DRAWTEXT(ISLASTBAR,【0.618】,'【0.618】'),COLORLIRED;
DRAWTEXT(ISLASTBAR,【0.809】,'【0.809】'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,【底】,'【地量】'),COLORGREEN;

 

 


公式2:


VOLUME:VOL,VOLSTICK;
顶:=REF(HHV(V,120),2);
底:=REF(LLV(V,120),2);
H08:=底+(顶-底)*0.082;
H19:=底+(顶-底)*0.191;
H38:=底+(顶-底)*0.382;
H中:=底+(顶-底)*0.5;
H61:=底+(顶-底)*0.618;
H80:=底+(顶-底)*0.809;
【底】:REFDATE(底,DATE),COLORGREEN;
【0.082】:REFDATE(H08,DATE),COLORRED;
【0.191】:REFDATE(H19,DATE),COLORYELLOW;
【0.382】:REFDATE(H38,DATE),COLORMAGENTA;
【0.5】:REFDATE(H中,DATE),COLORWHITE;
【0.618】:REFDATE(H61,DATE),COLORLIRED;
【0.809】:REFDATE(H80,DATE),COLORYELLOW;
【顶】:REFDATE(顶,DATE),COLORCYAN;
{下面内容不显示,留下输出的空间给各位}
DRAWTEXT(ISLASTBAR,【顶】,'【天量】'),COLORCYAN;
DRAWTEXT(ISLASTBAR,【0.082】,'【0.082】'),COLORRED;
DRAWTEXT(ISLASTBAR,【0.191】,'【0.191】'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,【0.382】,'【0.382】'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,【0.5】,'【0.5】'),COLORWHITE;
DRAWTEXT(ISLASTBAR,【0.618】,'【0.618】'),COLORLIRED;
DRAWTEXT(ISLASTBAR,【0.809】,'【0.809】'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,【底】,'【地量】'),COLORGREEN;
有人要飞狐版的在这里!!记得顶贴或加分哦!!VOL,VOLSTICK;
N1:=SYSPARAM(3);
N:=((N1 - SYSPARAM(2)) + 1);
HH:=HHV(vol,N);
LL:=LLV(vol,N);
最高:HH[N1],colorcyan;
最低:LL[N1],colorGREEN;
(最低 + ((最高 - 最低) * 0.082)),colorred;
(最低 + ((最高 - 最低) * 0.191));
(最低 + ((最高 - 最低) * 0.382));
(最低 + ((最高 - 最低) * 0.5)),colorwhite;
(最低 + ((最高 - 最低) * 0.618));
(最低 + ((最高 - 最低) * 0.809));
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'0.00↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.082)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'8.2%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'19.1%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'38.2%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'50%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'61.8%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'80.9%↑'),colorFFFF;
DRAWTEXT((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),'100%↑'),colorFFFF;
{以下可以不要}
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF(最低,BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.082)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.082)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.191)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.382)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.5)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.618)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 0.809)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;
DRAWNUMBER((BARSCOUNT(CLOSE) = SYSPARAM(2)),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),REF((最低 + ((最高 - 最低) * 1)),BARSLAST((BARSCOUNT(CLOSE) = SYSPARAM(2)))),2),SHIFT110,colorFFFF;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容