牛牛财神公式-通达信公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

游戏娱乐平台注册就送25

相关标签:

 

{牛牛的牛公式}

 

原理解析:


 

 来源:程序化99( WWW.naturesnaturalbeauty.com )

源码:

 

 

PJJ:=DMA((H + L + C * 2) / 4,0.9);JJ:=REF(EMA(PJJ,3),1);QJJ:=VOL / ((H - L) * 2 - ABS(C - O));XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2))+ IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));HSL:=XVL / 20 / 1.15;攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;GJJ:=EMA(攻击流量,2);DIFF:=(EMA(GJJ,12)-EMA(GJJ,26)),COLORGREEN;DEA:=MA(DIFF,2),COLORYELLOW;VA2:=LLV(LOW,33);VA3:=HHV(HIGH,21);VA4:=EMA((CLOSE-VA2)/(VA3-VA2)*100,10)*-1+100;趋势:=100-EMA(0.191*REF(VA4,1)+0.809*VA4,1);趋势线:=100-EMA(0.191*REF(VA4,1)+0.809*VA4,1);STICKLINE(DIFF>DEA AND 趋势线>REF(趋势线,1),HHV(H,5)*1.05,LLV(L,5)*0.95,4,0),COLOR781836;DRAWKLINE(H,O,L,C);V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);V2:=(1-7/100)*(DMA(CLOSE,V1));V3:=(1+7/100)*(DMA(CLOSE,V1));V5:=MA((LOW+HIGH+CLOSE)/3,5);支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 ORVAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};MA3:MA(C,3);MA5:MA(C,5),COLORWHITE;MA10:=MA(C,10),NODRAW;MA30:MA(C,34),NODRAW;五日乖离率:=(C-MA5)/MA5*100;BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;DD5:=MA5<REF(MA5,1);IF(DD5,MA5,DRAWNULL),COLOR00FF00;X0:=(3*C+L+O+H)/6;多空线: (20*X0+19*REF(X0,1)+18*REF(X0,2)+17*REF(X0,3)+16*REF(X0,4)+15*REF(X0,5)+14*REF(X0,6)+13*REF(X0,7)+12*REF(X0,8)+11*REF(X0,9)+10*REF(X0,10)+9*REF(X0,11)+8*REF(X0,12)+7*REF(X0,13)+6*REF(X0,14)+5*REF(X0,15)+4*REF(X0,16)+3*REF(X0,17)+2*REF(X0,18)+REF(X0,20))/210,COLORFF00FF,LINETHICK1;{用法:黄托底买进,绿压顶买出。}DD:=多空线<REF(多空线,1);IF(DD,多空线,DRAWNULL),COLORBLUE,LINETHICK2;A:=(MA5>多空线);IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT;A1:=(MA5<多空线);IF(A1,多空线,DRAWNULL),COLORWHITE;A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;A5:=EMA(CLOSE,12)-EMA(CLOSE,26);A6:=EMA(A5,9);A7:=(A5<-0.1 AND A5>A6);财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;CYS:=(EMA((CLOSE-V2)/V2,1)*100);AA0:=CYS;MIDD:=MA(CYS,20);CC0:=MIDD+0.85*STD(CYS,10);TM6:=AA0>CC0;IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;A0:=(L+H+C*2)/4;工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;A1X:=(工作-REF(工作,1))/REF(工作,1)*100;A2X:=(度假-REF(度假,1))/REF(度假,1)*100;G:=BARSLAST(CROSS(A1X,0));{KDJ}RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;金叉:=CROSS(J,D);死叉:=CROSS(D,J);买1:=(VAR14 OR VAR15) AND VAR11;买2:=(VAR14 OR VAR15) AND VAR4;买3:=(VAR14 OR VAR15) AND VAR2;买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);{涨停}STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;{跌停}STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;{蓝}STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;{红}STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;{绿}STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;{灰} STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;DRAWICON(VAR16,LOW-0.02,7);DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);STICKLINE(CROSS(A1X,0),C,O,1,0)COLORFFFFFF;STICKLINE(CROSS(0,A1X),C,O,1,0)COLORGREEN;AX:=XMA(C,3);DRAWICON(H/AX>1.05,H*1.01,2);N1:=6;AA:=REF(H,N1)=HHV(H,2*N1+1); AA1:=REF(L,N1)=LLV(L,2*N1+1);QY:=BACKSET(AA,N1+1); QY1:=BACKSET(AA1,N1+1);CC:=FILTER(QY,N1) AND H=HHV(H,N1+1); CC1:=FILTER(QY1,N1) AND L=LLV(L,N1+1);DDD:=BARSLAST(CC); DD1:=BARSLAST(CC1);GDTS:=IF(CC,CURRBARSCOUNT,0); DDTS:=IF(CC1,CURRBARSCOUNT,0);DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);GDCS1:=CONST(DINGBUTS); DDCS1:=CONST(DDTS1);GDCS13:=CONST(REF(HIGH,GDCS1-1)); DDCS13:=CONST(REF(L,DDCS1-1));DINGBUTS1:=REF(DINGBUTS,DDD+1); DDTS2:=REF(DDTS1,DD1+1);GDCS2:=CONST(DINGBUTS1); DDCS2:=CONST(DDTS2);GDCS23:=CONST(REF(HIGH,DINGBUTS1-1)); DDCS23:=CONST(REF(L,DDTS2-1));XG1:=BACKSET(ISLASTBAR,GDCS1); XD1:=BACKSET(ISLASTBAR,DDCS1);XG2:=BACKSET(ISLASTBAR,DINGBUTS1); XD2:=BACKSET(ISLASTBAR,DDTS2);XDD:=IF(DDCS13<=DDCS23,XD1,XD2);M:=INTPART(3*N1/5);AAA:=REF(H,M)=HHV(H,2*M+1);QYY:=BACKSET(AAA,M+1);CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);DDDD:=BARSLAST(CCC),NODRAW;GDTSS:=IF(CCC,CURRBARSCOUNT,0);DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);GDCS11:=CONST(DINGBUTSS);DINGBUTS11:=REF(DINGBUTSS,DDDD+1);GDCS22:=CONST(DINGBUTS11);AA11:=REF(L,M)=LLV(L,2*M+1);QY11:=BACKSET(AA11,M+1);CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);DD11:=BARSLAST(CC11);DDTSS:=IF(CC11,CURRBARSCOUNT,0);DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);DDCS11:=CONST(DDTS11);DDTS22:=REF(DDTS11,DD11+1);DDCS22:=CONST(DDTS22);HH1:= REF(H,GDCS1-1),NODRAW;HH2:= REF(H,GDCS2-1),NODRAW;HH11:= REF(H,GDCS11-1),NODRAW;HH22:= REF(H,GDCS22-1),NODRAW;GHH1:=MAX(MAX(REF(H,GDCS1-1),REF(H,GDCS2-1)),MAX(REF(H,GDCS11-1),REF(H,GDCS22-1))),NODRAW;DLL1:=MIN(MIN(REF(L,DDCS1-1),REF(L,DDCS2-1)),MIN(REF(L,DDCS11-1),REF(L,DDCS22-1))),NODRAW;GHH:=MAX(GHH1,HHV(H,10));DLL:=MIN(DLL1,LLV(L,10));DX1:=(REF(H,GDCS1-1)-REF(H,GDCS2-1))/(GDCS2-GDCS1),NODRAW;DX2:=(REF(H,GDCS11-1)-REF(H,GDCS22-1))/(GDCS22-GDCS11),NODRAW;GGAA:=DX1>0 AND (REF(H,(GDCS1-1))+DX1*GDCS1)>GHH*1.05,NODRAW;GGAB:=DX1<0 AND (REF(H,(GDCS1-1))+DX1*GDCS1)<DLL*0.95,NODRAW;DDX1:=IF(GGAA OR GGAB,0,1),NODRAW;GGBA:=DX2>0 AND (REF(H,(GDCS11-1))+DX2*GDCS11)>GHH*1.05,NODRAW;GGBB:=DX2<0 AND (REF(H,(GDCS11-1))+DX2*GDCS11)<DLL*0.95,NODRAW;DDDX1:=IF(GGBA OR GGBB,0,1),NODRAW;LX1:=(REF(L,DDCS1-1)-REF(L,DDCS2-1))/(DDCS2-DDCS1),NODRAW;LX2:=(REF(L,DDCS11-1)-REF(L,DDCS22-1))/(DDCS22-DDCS11),NODRAW;DDAA:=LX1<0 AND (REF(L,(DDCS1-1))+LX1*DDCS1)<DLL*0.95,NODRAW;DDAB:=LX1>0 AND (REF(L,(DDCS1-1))+LX1*DDCS1)>GHH*1.05,NODRAW;LLX1:=IF(DDAA OR DDAB,0,1);DDBA:=LX2<0 AND (REF(L,(DDCS11-1))+LX2*DDCS11)<DLL*0.95,NODRAW;DDBB:=LX2>0 AND (REF(L,(DDCS11-1))+LX2*DDCS11)>GHH*1.05,NODRAW;LLLX1:=IF(DDBA OR DDBB,0,1),NODRAW;长压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,DDX1),COLORYELLOW,LINETHICK2;长支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,LLX1),COLORYELLOW,LINETHICK2;长中轨:(长压力+长支撑)/2,POINTDOT,COLORYELLOW,LINETHICK4;短压力:DRAWLINE(CURRBARSCOUNT=GDCS22 ,H,CURRBARSCOUNT=GDCS11,H,DDDX1),COLORLIBLUE,LINETHICK1;短支撑:DRAWLINE(CURRBARSCOUNT=DDCS22 ,L,CURRBARSCOUNT=DDCS11,L,LLLX1),COLORLIBLUE,LINETHICK1;短中轨:(短压力+短支撑)/2,POINTDOT,COLORLIBLUE,LINETHICK4;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.naturesnaturalbeauty.com '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易58娱乐场送18元彩金'),COLORRED;


 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容