散户主力资金流指标源码-倚天版公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25

游戏娱乐平台注册就送25

M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(85,RSI),75,'▼'),COLORGREEN;
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
吸筹:IF(VAR8>100,100,VAR8)*VAR1,COLORRED;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,8,0),COLORRED;
散户线: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄家线:EMA(J,6),COLORFF00FF,LINETHICK2;

 

源码解析:

M赋值:55
N赋值:34
LC赋值:昨收
RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
FF赋值:收盘价的3日指数移动平均
MA15赋值:收盘价的21日指数移动平均
当满足条件85上穿RSI时,在75位置书写文字,画绿色
VAR1赋值:如果年份>=2038ANDMONTH>=1,返回0,否则返回1
VAR2赋值:昨日最低价*VAR1
VAR3赋值:最低价-VAR2的绝对值的3日[1日权重]移动平均/最低价-VAR2和0的较大值的3日[1日权重]移动平均*100*VAR1
VAR4赋值:如果收盘价*1.3,返回VAR3*10,否则返回VAR3/10的3日指数移动平均*VAR1
VAR5赋值:30日内最低价的最低值*VAR1
VAR6赋值:30日内VAR4的最高值*VAR1
VAR7赋值:如果收盘价的58日简单移动平均,返回1,否则返回0*VAR1
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7*VAR1
输出吸筹:如果VAR8>100,返回100,否则返回VAR8*VAR1,画红色
输出庄家吸筹:当满足条件吸筹>-150时,在0和吸筹位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
输出散户线: 100*(M日内最高价的最高值-收盘价)/(M日内最高价的最高值-M日内最低价的最低值),COLORFFFF00,线宽为2
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
输出庄家线:J的6日指数移动平均,COLORFF00FF,线宽为2
 
 

 

有思路,想编写各种指标公式,程序化交易58娱乐场送18元彩金,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容