快慢多空或火车轨指标源码-仟家信公式 -程序化交易(naturesnaturalbeauty.com) - 游戏娱乐平台注册就送25
您现在的位置:程序化交易>> 外汇现货>> 仟家信等>> 仟家信公式>>正文内容

游戏娱乐平台注册就送25

快慢多空或火车轨指标公工源码:

 

S:=CROSS(CLOSE,EMA2(HIGH,30));
X:=CROSS(EMA2(LOW,30),CLOSE);
WS:=BARSLAST(S) 1;
WX:=BARSLAST(X) 1;
SS:=CROSS(SUM(S,WX),0.5);
XX:=CROSS(SUM(X,WS),0.5);
STICKLINE(CLOSE>EMA2(HIGH,30),EMA2(HIGH,30),EMA2(LOW,30),COLORMAGENTA,1);
STICKLINE(CLOSE<EMA2(LOW,30),EMA2(LOW,30),EMA2(HIGH,30),COLORBLUE,1);
STICKLINE(CLOSE>EMA2(HIGH,150),EMA2(HIGH,150),EMA2(LOW,150),COLORLIGHTRED,1);
STICKLINE(CLOSE<EMA2(LOW,150),EMA2(LOW,150),EMA2(HIGH,150),COLORLIGHTGREEN,1);
PARTLINE(CLOSE>EMA2(HIGH,30),EMA2(HIGH,30),COLORMAGENTA);
PARTLINE(CLOSE<EMA2(HIGH,30),EMA2(HIGH,30),COLORBLUE);
PARTLINE(CLOSE>EMA2(LOW,30),EMA2(LOW,30),COLORMAGENTA);
PARTLINE(CLOSE<EMA2(LOW,30),EMA2(LOW,30),COLORBLUE);
PARTLINE(CLOSE>EMA2(HIGH,150),EMA2(HIGH,150),COLORLIGHTRED);
PARTLINE(CLOSE<EMA2(HIGH,150),EMA2(HIGH,150),COLORLIGHTGREEN);
PARTLINE(CLOSE>EMA2(LOW,150),EMA2(LOW,150),COLORLIGHTRED);
PARTLINE(CLOSE<EMA2(LOW,150),EMA2(LOW,150),COLORLIGHTGREEN);
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,COLORRED,0);
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,COLORCYAN,0);
DRAWTEXT(SS,LOW,'买入');
DRAWTEXT(XX,HIGH,'卖出');

 

 

 

 

源码解析:

 

S赋值:收盘价上穿EMA2(最高价,30)
X赋值:EMA2(最低价,30)上穿收盘价
WS赋值:上次S距今天数 1
WX赋值:上次X距今天数 1
SS赋值:S的WX日累和上穿0.5
XX赋值:X的WS日累和上穿0.5
当满足条件收盘价>EMA2(最高价,30)时,在EMA2(最高价,30)和EMA2(最低价,30)位置之间画柱状线,宽度为画洋红色,1不为0则画空心柱.
当满足条件收盘价<EMA2(最低价,30)时,在EMA2(最低价,30)和EMA2(最高价,30)位置之间画柱状线,宽度为画蓝色,1不为0则画空心柱.
当满足条件收盘价>EMA2(最高价,150)时,在EMA2(最高价,150)和EMA2(最低价,150)位置之间画柱状线,宽度为COLORLIGHTRED,1不为0则画空心柱.
当满足条件收盘价<EMA2(最低价,150)时,在EMA2(最低价,150)和EMA2(最高价,150)位置之间画柱状线,宽度为COLORLIGHTGREEN,1不为0则画空心柱.
PARTLINE(收盘价>EMA2(最高价,30),EMA2(最高价,30),画洋红色)
PARTLINE(收盘价<EMA2(最高价,30),EMA2(最高价,30),画蓝色)
PARTLINE(收盘价>EMA2(最低价,30),EMA2(最低价,30),画洋红色)
PARTLINE(收盘价<EMA2(最低价,30),EMA2(最低价,30),画蓝色)
PARTLINE(收盘价>EMA2(最高价,150),EMA2(最高价,150),COLORLIGHTRED)
PARTLINE(收盘价<EMA2(最高价,150),EMA2(最高价,150),COLORLIGHTGREEN)
PARTLINE(收盘价>EMA2(最低价,150),EMA2(最低价,150),COLORLIGHTRED)
PARTLINE(收盘价<EMA2(最低价,150),EMA2(最低价,150),COLORLIGHTGREEN)
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为画红色,0不为0则画空心柱.
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为画青色,0不为0则画空心柱.
当满足条件SS时,在最低价位置书写文字
当满足条件XX时,在最高价位置书写文字
 

 

如果以上指标公式不适用于您常用的行情软件

或者您想改编成选股公式,以便快速选出某种形态个股的话,

可以联系我们相关技术人员 QQ: 262069696  点击在线交流进行 有偿 改编!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容